Issue affecting inbound calls.
Incident Report for Dialpad Japan
Resolved
From approximately 6:58-7:08pm PST.
Posted 10 months ago. Dec 10, 2018 - 19:24 PST
This incident affected: Telephony Infrastructure: Inbound calls.